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iiExercise #
Adobe InDesign

In order to do this exercise you need to download an InDesign file. You can find the 1.	
file here: http://www.nobledesktop.com/nyidug.html 

Extract the file 2.	 twenty.indd from the twenty.zip archive.

Open the file 3.	 twenty.indd.

If you get a message about modified links, click Don’t Fix. We do not need the 
original images in this exercise.

Save the file as 4.	 yourname-twenty.indd.

In the 5.	 Pages panel, scroll to the last page of the document. 

Drag a 6.	 B Index master to the end of the document, so it becomes page 39. This is 
where we are going to put our artist index.

Creating the Index Markers
Creating an index starts with inserting Index Markers. In the great scope of life, 
sometimes index entries will be on their own, and sometimes they will be included 
under a “Topic.” In this case, we will index the title of works of art underneath a 
topic — the artist’s name. Unfortunately, there is no quick and easy way to do this 
procedure. Inserting the index markers is time-consuming and tedious. But, once it 
is done, building the index will be easy.

Go to page 7.	 2. 

Highlight the text 8.	 Water Lilies.

Go into 9.	 Window > Type & Tables > Index.

You could hit the10.	  Create a new index entry icon (  ) at the bottom of the palette, 
but we encourage you to go into the palette menu, because when you do that, you 
see the keyboard shortcut (which you will probably soon want to use, since this is 
such a tedious process). Go into the Index panel menu (   ) and choose New page 
Reference.

You will see the 11.	 New Page Reference dialog, with the text Water Lilies in the Topic 
Level 1 field. We actually want this to be a second-level topic, under the first level 
topic of the artist name. Click the down arrow (   ) to move it down to level 2.

Now that 12.	 Water Lilies is in the Level 2 field, click in the Level 1 field and type the 
artist’s name, Monet, Claude.

13.	 You can click OK since you are done with this panel for now.

Take a look at the Index panel. If you scroll down to the letter 14.	 M, you 
will see a triangle. Click it. You will see several names with triangles, 
and at the bottom of those names will be Monet, Claude. Click on that 
triangle, and then on the Water Lilies entry, until you get the entry as 
shown to the right:

You see to the right that there are already some index entries for other 15.	
artists. That’s because we have mercifully added those index markers 
for you. That is so that we can have a complete index without making 
you enter 37 index entries.

Go to page 3.16.	

Highlight the text 17.	 The Old Guitarist.
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Go into the  18.	 Index panel menu (   ) and choose New Page Reference. Going 
forward, you can use the keyboard shortcut whenever you get tired of clicking in the 
menu: Ctrl–U  or Cmd–U .

Once in the Index panel, click the 19.	 down arrow (   ) to move it down to level 2.

You can either type in 20.	 Picasso, Pablo, or you can scroll down the list below and find 
his name, since he already has one painting indexed. It’s a little easier to type it in but 
if you prefer to avoid typos, just find his name and double-click to bring it into the 
topic field. Click OK when you are done.

Now for the ugly part of this exercise. All right, it’s not that ugly. Go through 21.	
pages 4–7 and add the titles underneath the artist’s names. Add each one as a page 
reference, putting the artist name in the Level 1 field. Again, we’ve had mercy on 
you and indexed pages 8–38. 

Building the Index
Go to page 39, the last page that we added before.22.	

In the 23.	 Index panel click the Generate Index (   ) button.

Most of the settings you’ll keep, but we’ve pointed out some below that you need to 24.	
change. If you don’t see all these options, click the More Options button on the right. 
(Don’t click OK till we say):

Delete any text

LEAVE THIS 
CHECKED

Choose these 
two styles

Type ^t here  
(FOR A TAB)

Choose THIS 
STYLE

Here are all the things you have to do: 
— Under Title: delete whatever is there 
— Check Include Index Section Headings 
— Under Level 1 choose index artist 
— Under Level 2 choose index text 
— Under Section Heading choose index letter headings 
— Under Entry Separators, Following Topic, type ^t (or choose Tab from the  menu)

Now click 25.	 OK, and notice that your cursor is loaded with text.

Place the text in the box on page 39.26.	
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Cleaning it up
Any time you create an index, there will be some cleanup. In this case, we need to put 
the title on the same line as the artist. We’ll use a GREP search to do it. 

Do an 27.	 Edit > Find/Change... and make sure More Options are showing.

Make sure the 28.	 GREP tab is highlighted.

Under 29.	 Find what: delete anything that is there, and from the  menu to its right, 
choose End of Paragraph.

Under 30.	 Change to: delete anything that is there, and from the  menu to its right, 
choose White Space > Nonbreaking Space.

Insert 3 more nonbreaking spaces, so you have 4 altogether.31.	

Below where it says 32.	 Find Format, click on the  menu (you can also just click in the 
empty box below Find Format). Make Paragraph Style index artist if it is not already.

Below where it says 33.	 Change Format, click on the  menu (you can also just click in 
the empty box below Change Format). Make Paragraph Style index text.

Make sure under 34.	 Search: that Story is selected. If you can’t choose story, make sure 
you have clicked inside the index text box. 

Hit 35.	 Find, then Change All.

Click36.	  Done.

Notice that all the bold is gone. That’s because the style was changed to simply index 
text. We will now create a bold character style that we can “nest” into the index text 
style, through the first nonbreaking space.

Highlight the first artist name, 37.	 Bacon, Francis.

Make it 38.	 bold.

Go into the 39.	 Character Styles panel.

From the 40.	 Character Styles panel menu (   ), choose New Character Style

Name it 41.	 artist name bold, then just click OK

Go into the 42.	 Paragraph Styles panel. index text should be highlighted. Right–click on 
the name index text (or Control–click on it) and choose Edit “index text.” You’ll do a 
few steps in this dialog.

On the left, select 43.	 Drop Caps and Nested Styles.

Click on 44.	 New Nested Style.

Change 45.	 [None] to artist name bold.

Change 46.	 Words to Non-breaking spaces.

So it should say artist name bold through 1 Non-breaking space.

Click OK, you are done. All of the artist names should now be bold!47.	

To be completist, go ahead and add another page after page 39, and link the boxes so 48.	
that you see the complete index. 

Understand that the Index text has now been manipulated. If you ever need to 
rebuild the index, you will need to do the GREP search again to get the artist back 
on the same line as the title.  



Copyright © 2002–2007 Noble Desktop, LLC Page 4

iiExercise #
Adobe InDesign Double Indexes with GREP

Creating a Title Index
We have a new problem. There needs to be a Title index as well! Unfortunately, we 
cannot build a Title index simply by switching the data in the index we have built. 
However, we can use a GREP search to swap the title and artist in the current index. 
We’ll then sort the paragraphs alphabetically.

Add a new 49.	 B Index page after page 40.

If you would like, change the running head from 50.	 Index by Artist to Index by Title. 
Remember that to unlock the text box you will need to Cmd/Ctrl–Shift–Click on the 
box first. 

Select and copy all of the text on page 51.	 39.

Go to page 52.	 41 and Cmd/Ctrl–Shift–Click on the main text box to unlock it.

Click in the box with the 53.	 Type tool.

Paste all of the text into that box.54.	

swapping the artist and title
You are now ready to use GREP to swap some data. We’re going to show you how 
to do it two ways: the fast way, and the “learn it” way. If you want to do it fast, keep 
going with the FAST section. If you want to “build” the GREP search and learn how 
to do it from the ground up, skip to the BUILD IT section just ahead.

FAST
Click in the top of the box on page 41, then go into 55.	 Edit > Find/Change...

Make sure 56.	 GREP is highlighted.

Under 57.	 Search, make sure it says Story.

OK, here is the fast way. We’ll show you how to build this expression later, but just 58.	
so you can see it work type this into the Find what: ^(.+)~S~S~S~S(.+)\t

Put this under 59.	 Change to: $2~S~S~S~S$1\t

Next to 60.	 Find Format, click the    to remove formatting. 

Next to 61.	 Change Format, click the    to remove formatting. 

Hit 62.	 Find, then hit Change All. 

All of the titles are now first, and bold. All we have to do is alphabetize, right? No 63.	
problem. First, select all of the text in the box.

Open the Scripts Panel (64.	 Window > Automation > Scripts), then under  
Application > Samples > Javascript double-click SortParagraphs.jsx.

Woot! You are done and dunner! You have now completed two different indexes. 
Actually, you will still need to fix the letter headings manually, because there are now 
some new letters used (such as the letter A, since there are titles that start with A 
but no artists). Go ahead and fix those things if you wish. And if you really want the 
titles to work right, you will need to cut the word “The” and paste them at the end 
of a few titles, such as The Old Guitarist, which should be Old Guitarist, The. This 
is minor in the great scheme of things. Make those changes then resort, then fiddle 
with the letter headings.
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OK, below is how to build that GREP search. If you are not interested in how to do 
it, you are really done. Finito! But if you want to know the inner workings of GREP, 
it’s good practice.

BUILD IT
Go into 65.	 Edit > Find/Change...

Make sure 66.	 GREP is highlighted.

Under 67.	 Search, make sure it says Story.

Under 68.	 Find what: delete anything that is there, and from the  menu to its right, 
choose Locations > Beginning of Paragraph.

In that same 69.	  menu, also choose Wildcards > Any Character.

Again in the 70.	  menu, choose Repeat > One or More Times.

Then do 71.	 White Space > Nonbreaking Space.

Do 4 of those altogether or type 72.	 ~S a total of four times

Then 73.	 Wildcards > Any Character.

Then 74.	 Repeat > One or More Times.

Then 75.	 Tab.

Add parentheses around the 76.	 .+ in both places. You need to do this if you want the 
found text to be saved as a variable.

Great. Now copy everything in that 77.	 Find what: field.

Paste it into the 78.	 Change to: field.

Change the 79.	 ^(.+) to $2. You don’t need the start of the paragraph, and the $2 means 
place the 2nd variable, or group of characters, in that place.

Change the next 80.	 (.+) to $1. That places the first variable into that location. See how 
it works? Nothing else needs to change. It’s just swapping the found text!

Next to 81.	 Find Format, click the little garbage can to remove formatting. 

Next to 82.	 Change Format, click the little garbage can to remove formatting. 

Hit 83.	 Find, then hit Change All. 

All of the titles are now first, and bold. All we have to do is alphabetize, right? No 84.	
problem. First, select all of  the text in the box.

Open the Scripts Panel (85.	 Window > Automation > Scripts), then under  
Application > Samples > Javascript double-click SortParagraphs.jsx.

Double woot! You are done done dunner! And that is the end of this exercise.

Actually, you might still need to fix the letter headings manually, because there are 
now some new letters used (such as the letter A, since there are titles that start with A 
but no artists). Go ahead and fix those things if you wish. And if you really want the 
titles to work right, you will need to cut the word “The” and paste them at the end 
of a few titles, such as The Old Guitarist, which should be Old Guitarist, The. This 
is minor in the great scheme of things. Make those changes then re-sort, then fiddle 
with the letter headings.

 


