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Using Master Pages
Master Pages allow you to apply objects that repeat on multiple pages from one 
master page source, sort of like stationary. I use them for common things like page 
numbers and running head elements (author, chapter title, section, etc.)

When you first create a document, you have 2 master pages to work with: “None” 
and “A-Master”. None will create a blank page while A-Master will initially be blank 
until you start adding items to it. The pages you apply A-Master to will be linked to 
A-Master—make a change to it and the result will also show up on any page linked 
to A-Master.

Pages in your document that are based on a master will show the Prefix of the 
master they are associated with in their upper outside corner.

Overriding a Master Item
When you apply a master page to a document page, all objects on the master, called 
master items, appear on the document page. Sometimes you want a specific page to 
be only slightly different from a master. In this situation you don’t need to re-create 
the master layout on the page or create a new master—you can override or detach 
the master item, and other master items on the document page will continue to 
update with the master.

To Override a Master Item
1.	 Make sure the master item can be overridden. (You can override a master item 

only if Allow Master Item Overrides On Selection is selected in the Pages Panel 
menu for that item. Alternatively, turn this off for items on Master Pages that you 
do not wish to be overridden).

2.	 To override specific master items on a document page, press Command+Shift/
Control+Shift and click the item (or drag to select multiple items).

3.	 To override all master page items on a document spread, target the spread, and 
then choose Override All Master Page Items in the Pages Panel menu. You can 
now select and modify any and all master items as you wish.

Once you override any master item, its dotted bounding box becomes a solid line, to 
show that a local copy has been created.

Basing One Master Page on Another Master Page
You can have many different master pages, and master pages can be based on other 
master pages. This comes in handy, for example, when a document will contain 

The letter “A” on the page indicates 
which Master Page is applied to it. In 
this case, it is the A-Master.

This checkerboard icon indicates a 
page that contains transparency.

This downward pointing arrow 
indicates a section, and you can 
have more than one section in your 
document. Double-clicking on the 
arrow will bring up the Numbering 
and Section Options dialog box.
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both 2-column and 3-column text flows, but the master elements (color blocks, date 
information, etc.) remain the same. Should any of your master elements change (a 
different color scheme, for instance), you need only alter the parent master . . . the 
change will automatically trickle down to the child masters that are based upon the 
parent rather than having to change all the masters separately. This is a powerful 
way to keep a consistent yet varied design up to date.

Applying a Master to a Document Page or Spread

1.	 To apply a master to one page, drag the master page icon to a page icon in the 
Pages Panel. When a black rectangle surrounds the desired page, release the 
mouse button.

2.	 To apply a master to a spread, drag the master page icon to a corner of the spread 
in the Pages Panel. When a black rectangle surrounds all pages in the desired 
spread, release the mouse button.

Applying a Master to Multiple Pages

1.	 In the Pages Panel, select the pages to which you want to apply a new master.
2.	 From the Pages Panel flyout menu, choose Apply Master To Pages, select a master 

from the Apply Master drop down menu, make sure that the page ranges in the 
To Pages option are the ones you want, and click OK. You can apply a master to 
multiple pages at once. For example, you can type 5, 7–9, 13–16 to apply the same 
master to pages 5, 7–9, and 13–16.

Unassigning Masters from Document Pages
1.	 Apply the None master from the Masters section of the Pages panel.

When you unassign a master from a page, its layout and items no longer apply to the 
page. If a master contains most of the elements you want, but you need to customize 
the appearance of a few pages, you can override master items and edit or modify 
them on those document pages, instead of unassigning the master.
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Type Styles in InDesign
InDesign has two types of text styles: paragraph styles, which apply formatting for 
both character and paragraph attributes; and character styles, which apply formatting 
for only character attributes.

When you create a new document, it will contain the Basic Paragraph style. The 
Basic Paragraph style is part of every document and is automatically applied to all 
new text. If you change the definition of the Basic Paragraph style, it automatically 
updates all text that has been styled with the Basic Paragraph style. The Basic 
Paragraph style can be modified but not deleted.

The easiest way to define a style is to format some text and define the style by 
example.

Character Styles
Character Styles allow you to set specific attributes that override the paragraph style 
character attributes. You can also format the text and then define a character style by 
example.

One of the major differences between InDesign and QuarkXPress is that 
InDesign allows you to define a character style with only one attribute. This allows 
one character style to be used with several different paragraph styles. Unfortunately 
however, character styles cannot be combined.

Style Groups
Just as you can create folders to organize your files on your computer, you can also 
create folders (Style Groups) that allow you to organize your styles (and not just 
paragraph and character styles, but object, table, and cell styles too).

Loading and Importing Styles
Text style names are case-sensitive, so that a paragraph style name of Body Text will 
be added as a separate style to a document that already has a paragraph style named 
body text.

When you load styles from one document to another, there may be times when 
the styles coming into the document have the same name, but different definitions. 
When this style conflict happens, you have two choices to resolve the conflict:

1.	 Auto-Rename imports the style with a suffix to differentiate it from the existing 
style.

2.	 Use Incoming Style Definition changes the existing style to match the imported 
style definition.

Importing Text Styles from Word
When you place text from word processing programs such as Microsoft Word into 
InDesign, the text styles from the imported text are added to the document. Use the 
Microsoft Word Import Options to choose how style conflicts are resolved. For instance, 
you can choose to have the InDesign style override the incoming style, have the 
incoming style override the InDesign style, or have the incoming style automatically 
renamed to add it to the list of styles in the panel. You can also use the Style Mapping 
dialog box to map an incoming style to the definition of an existing style.

1.	 Choose File > Place and navigate to the Word file you want to import.
2.	 Before selecting Open, select Show Import Options, which will open the Microsoft 

Word Import Options dialog box.
TIP You can access the Import Options without always showing them by holding 
Shift and clicking Open.

3.	 Select Preserve Styles and Formatting from Text and Tables.
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4.	 Select Import Styles Automatically (this will allow you to choose how style 
conflicts are resolved).

	 or
5.	 Select Customize Style Import (this will allow you to map one style to another).

To Resolve Style Conflicts
1.	 Choose Use InDesign Style Definition to have the InDesign style override the 

incoming style.
2.	 Choose Redefine InDesign Style to have the incoming style override the InDesign 

style.
3.	 Choose Auto Rename to add the incoming style to the list of styles in the 

InDesign style panel.

After import, be sure to check your Paragraph and Character Style Panels. A disk 
icon indicates the style definition came from the imported text. The disk icon will 
disappear if you modify the imported style.

To map one style to another
1.	 In the Microsoft Word Import Options dialog box, select Customize Style Import 

and click the Style Mapping button to open the Style Mapping dialog box.
2.	 Under the InDesign Style column, choose one of the styles from the pop-up 

menu for each of the incoming Word styles.
3.	 Click OK to close the Style Mapping dialog box and OK again to Import the text.

TIP If you import text from Word that already has styles applied, make sure that 
no character style is selected in your InDesign Character Styles Panel, as all your 
imported text will take on the definition of the selected character style.

Clearing Style Overrides
You can use the Clear Overrides button to clear text overrides in a text selection.

To clear the local formatting in a text selection
1.	 Select the text you want to clear (to override all your text, choose Edit > Select 

All).
2.	 Click the Clear Overrides button in the Paragraph Styles or Control panel (or you 

can Option/Alt+click the style name in the Paragraph Styles Panel). This will 
change the local formatting in the selection to the underlying paragraph style.

To clear only local character formatting in a text selection
1.	 Select the text you want to clear.
2.	 Command/Control+click the Clear Overrides button. This changes the local 

character formatting in the selection to the underlying paragraph style.

Panel Flyout Menu

Quick Apply

Delete Style

New StyleStyle Group

Clear Overrides
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To clear only local paragraph formatting in a text selection
1.	 Select the text you want to clear.
2.	 Command-Shift/Control-Shift+click the Clear Overrides button. This changes 

the local paragraph formatting in the selection to the underlying paragraph style.

To override character styles and local formatting
1.	 Place your insertion point in the paragraph you want to override
2.	 Option-Shift/Alt-Shift+click the name of the paragraph style. This clears both 

the character styles and the local formatting applied to the text.

Redefining a Style
One of the advantages of using styles is that when you alter a style, all other text 
defined by that style is redefined as well.

To redefine a style
1.	 Double-click the style name in the panel. This opens the Style Options dialog 

box, where you can change style attributes. When you press OK, the style is 
redefined and all text that has that style applied to it is updated with the new 
attributes.

You can also redefine a style by example:

1.	 Select the text that has the style applied to it.
2.	 Apply local formatting via the Control, Paragraph, and/or Character Panels. A 

plus sign (+) will appear next to the style name in the Paragraph/Character Styles 
Panel, indicating an override.

3.	 Choose Redefine Style from the Styles Panel flyout menu. The style is redefined 
based on the modified example, and the plus sign (+) disappears.

Breaking the link to a style
1.	 Place your insertion point in the paragraph you want to override.
2.	 Choose Break Link to Style from the Paragraph/Character Styles Panel flyout 

menu. This removes the style from the text, but does not change its formatting.

Deleting a Style
When you delete a style, either by dragging the style name to the Paragraph Style/
Character Style Panel’s trash icon or choosing Delete Style from the panel’s flyout 
menu, an alert box will appear. Use the pop-up menu to choose what Paragraph/
Character Style to replace it with, or choose [None]. When deleting Character 
Styles, select the Preserve Formatting checkbox to convert the character style into 
local formatting.

For more information on moving text from Microsoft Word to InDesign and 
retaining formatting, see http://www.mackeycomposition.com/WordtoInDesign.pdf
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Text Variables
A text variable is an item you insert in your document that varies according to the 
context. For example, the “Last Page Number” variable displays the page number of 
the last page of the document. If you add or remove pages, the variable is updated 
automatically.

InDesign includes several preset text variables that you can insert in your 
document. You can edit the format of these variables, or you can create your own. 
Some variables, such as “Running Header” and “Chapter Number,” are especially 
useful for adding to Master Pages to ensure consistent formatting and numbering. 
Other variables, such as “Creation Date” and “File Name,” are useful for adding to 
the slug area for printing. Altogether, InDesign includes seven preset Text Variables. 
You can create unlimited numbers of variations of each and add your own text.

Types of Variables
Chapter Number
A variable created with the Chapter Number type inserts the chapter number. You can 
insert text before or after the chapter number, and you can specify a numbering style.

Creation Date, Modification Date, and Output Date
Creation Date inserts the date or time the document is first saved; Modification Date 
inserts the date or time the document was last saved to disk; Output Date inserts 
the date or time the document starts a print job, exports to PDF, or packages the 
document. You can insert text before and after the date, and you can modify the date 
format for all date variables.

TIP You can type date formats directly into the Date Format box, or you can choose 
format options by clicking the triangle to the right of the box. For example, the date 
format “MM/dd/yy” displays as 12/22/07. By changing the format to “MMM. d, yyyy” 
the date will display as Dec. 22, 2007.

Date variables use the language applied to text. For example, the creation date may 
appear in Spanish text as “01 diciembre 2007” and in German as “01 Dezember 2007.”

A full table of Date Codes is available at the end of this section.

File Name
This variable inserts the name of the current file into the document. It’s commonly 
added to the slug area of the document for printing or used in headers and footers.

Last Page Number
The Last Page Number type is useful for adding the total number of pages in a 
document to headers and footers using the common “Page 3 of 12” format. In this 
case, the number 12 is generated by the Last Page Number, and it’s updated whenever 
pages are added or removed. You can insert text before or after the last page number, 
and you can specify a numbering style.

Running Header (Paragraph or Character Style)
By default, the Running Header variables insert the first or last occurrence (on the 
page) of the text to which the specified style is applied.

Custom Text
This variable is commonly used for inserting placeholder text, or a text string that 
may need to be changed quickly. For example, if you’re working on a project that 
uses a code name for a company, you can create a custom text variable for the code 
name. When you are able to use the real company name, you can simply change the 
variable to update all the occurrences.

To insert special characters in a text variable, click the triangle to the right of the 
text box.
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Creating Text Variables
The options available for creating the variable depend on the type of variable you 
specify. For example, if you choose the “Chapter Number” type, you can specify text 
to appear both before and after the number, and you can specify the numbering style. 
You can create several different variables based on the same variable type, so you 
could create one variable that displays “Chapter 1” and another that displays “Ch. 1.”

Similarly, if you choose the “Running Header” type, you can specify which 
style is used as the basis for the header, and you can select options for deleting end 
punctuation and changing the case.

If you want to create text variables for use in all new documents you create, do so 
with no documents open. Otherwise, the text variables you create appear only in the 
current document.

1.	 Choose Type > Text Variables > Define.
2.	 Click New, or select an existing variable and click Edit.
3.	 Type a name for the variable, such as “Full Chapter” or “Running Title.”
4.	 From the Type menu, choose a variable type, specify the options for that type, 

and then click OK.

Different options are available depending on the variable type you select. You can 
also load Text Variables from another document, or drag them in from a Library or 
Snippet.

Text Before/Text After
For all variable types (except Custom Text), you can specify text that will be 

added before or after the variable. For example, you can add the word “of” before 
the Last Page Number variable and the phrase “total pages” after the variable to 
create an “of 12 total pages” effect. You can also paste text into the boxes, but special 
characters such as tabs and auto page numbers are stripped out. To insert special 
characters, click the triangle to the right of the text box.

Style
For all numbered variable types, you can specify the numbering style. If [Current 

Numbering Style] is selected, the variable uses the same numbering style selected in 
the document’s Numbering & Section Options dialog box.

Inserting Text Variables
1.	 Place the insertion point where you want the variable to appear.
2.	 Choose Type > Text Variables > Insert Variable, and then choose the variable you 

want to insert.

The variable appears on the page as if you’d typed it in the document. For example, 
the Creation Date variable might appear as December 22, 2007. If you choose Type 
> Show Hidden Characters, the variable instance is surrounded by a box using the 
current layer color.

Formatting Variables
Formatting options for Variables are limited in that they take on the formatting 
of surrounding text. Once in the text frame you can change the formatting as you 
would regular text, but it’s all or nothing.

Converting Text Variables to Text
To convert a single instance, select the text variable in the document window, and 
then choose Type > Text Variables > Convert Variable To Text. To convert all instances 
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of the text variable in the document, choose Type > Text Variables > Define, select the 
variable, and then click Convert To Text. Text Variables must be converted to text if 
you are downsaving to InDesign CS2, or they will be removed in the new CS2 file.

Limitation
An unfortunate limitation of Text Variables is that they will never wrap or break. 
Regardless of how tall your text frame is, if it’s narrower than the variable would be 
in the current text formatting, it will be overset or compressed.

Import Text Variables from Another Document
Text Variables can be loaded into the current document from another document:

1.	 Choose Type > Text Variables > Define.
2.	 Click Load, and then double-click the document that has the variables you want 

to import.
3.	 In the Load Text Variables dialog box, make sure that a check mark appears next 

to the variables you want to import. If any existing variable has the same name as 
one of the imported variables, choose one of the following options under Conflict 
With Existing Text Variable, and then click OK:

	� Use Incoming Definition Overwrites the existing variable with the loaded variable 
and applies its new attributes to all text in the current document that used the 
old variable. The definitions of the incoming and existing variables are displayed 
at the bottom of the Load Text Variables dialog box so that you can view a 
comparison.

	 Auto-Rename Renames the loaded variable.
4.	 Choose Done, and then click OK.
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Text Variable Date Format Date Codes

Abbreviation Description Example

M Month number, no leading 
zero 8

MM Month number, leading zero 08

MMM Abbreviated month name Aug

MMMM Full month name August

d Day number, no leading zero 5

dd Day number, leading zero 05

E Weekday name, abbreviated Fri

EEEE Full weekday name Friday

yy or YY Year number, last two digits 07

y or YYYY Full year number 2007

G or GGGG Era, abbreviated or expanded AD or Anno Domini

h Hour, no leading zero 4

hh Hour, leading zero 04

H Hour, no leading zero, 24‑hour 
format 16

HH Hour, leading zero, 24‑hour 
format 16

m Minute, no leading zero 7

mm Minute leading zero 07

s Second, no leading zero 7

ss Second, leading zero 07

a AM or PM, two characters PM

z or zzzz Time zone, abbreviated or 
expanded PST or Pacific Standard Time
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Smart Text Reflow
You can use the Smart Text Reflow feature to add or remove pages when you’re 
typing or editing text. This feature is useful when you’re using InDesign as a text 
editor and you want a new page to be added whenever you type more text than 
can fit on the current page. It’s also useful in avoiding overset text or empty pages 
for situations in which the text flow changes due to editing text, showing or hiding 
conditional text, or making other changes to the text flow.

By default, Smart Text Reflow is limited to master text frames—text frames that 
are on a master page. If the document includes facing pages, master text frames 
must appear on both left and right master pages, and the master text frames must be 
threaded for Smart Text Reflow to work.

You can change settings to allow pages to be added or removed when working 
in text frames that aren’t based on master pages. However, a text frame must be 
threaded to at least one other text frame on a different page for Smart Text Reflow to 
work.

Smart Text Reflow settings appear in Type preferences. These settings apply to 
the current document. To change default settings for all new documents, close all 
documents and specify the settings.

1.	 Choose InDesign > Preferences > Type (Mac OS) or Edit > Preferences > Type 
(Windows).

2.	 Select Smart Text Reflow.
3.	 Select any of the following options and then click OK.

Add Pages To Use this option to determine where the new page is created. For 
example, suppose you have a three-page document with text frames on the first two 
pages and a full-page graphic on the third page. If you’re typing to the end of page 
two, you can determine whether the new page is added before or after the full-page 
graphic on the third page. Choose End Of Story to add a new page after the second 
page. Choose End Of Document to add a new page after the page with the full-page 
graphic.

Limit To Master Text Frames If this option is turned off, you can also add or 
remove pages when editing text frames that aren’t based on master pages. To prevent 
unwanted text reflow from occurring, Smart Text Reflow takes effect only if the text 
frame you’re editing is threaded to at least one other text frame on a different page.

Preserve Facing-Page Spreads This option determines whether facing-page spreads 
are preserved when text is reflowed in the middle of a document. If this option is 
selected when text reflows in the middle of the document, a new two-page spread is 
added. If this option is not selected, a single new page is added, and subsequent pages 
are “shuffled.”

If your layout includes design elements specific to the right or left side of the 
spread, turn on this option. If your left and right pages are interchangeable, you can 
turn off this option. This option is dimmed if the document does not have facing 
pages.

Delete Empty Pages Select this option to delete pages when you edit text or hide 
conditions. Pages are deleted only if the emptied text frame is the only object on the 
page.


